六狼论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

新浪微博账号登陆

只需一步,快速开始

搜索
查看: 96|回复: 0

Linux下通过apxs命令给Apache添加模块

[复制链接]

升级  10%

64

主题

64

主题

64

主题

举人

Rank: 3Rank: 3

积分
230
 楼主| 发表于 2013-2-5 01:23:11 | 显示全部楼层 |阅读模式
Linux下通过apxs命令给Apache添加模块
2010-05-26 14:04
下面是使用apxs工具给apache添加模块

添加的模块:
LoadModule proxy_module       libexec/mod_proxy.so
LoadModule rewrite_module     libexec/mod_rewrite.so
LoadModule headers_module     libexec/mod_headers.so

添加方法:
1. 进入apache 源文件modules目录
cd apache/src/modules/

2. 安装 proxy_module
> cd proxy
> /user/local/apache/bin/apxs -i -a -c *.c

3. 安装 rewrite_module
> cd standard
> /user/local/apache/bin/apxs -i -a -c mod_rewrite.c

4. 安装 headers_module
> cd standard
> /user/local/apache/bin/apxs -i -a -c mod_headers.c

但是,用这种方法添加的proxy不可用,提示错误:

/apache/httpd/bin/apachectl configtest

httpd: Syntax error on line 58 of /apache/httpd-2.2.3/conf/httpd.conf: Cannot load /apache/httpd-2.2.3/modules/mod_proxy.so into server: /apache/httpd-2.2.3/modules/mod_proxy.so: undefined symbol: proxy_lb_workers

所以,应该这样:

在Linux系统下,需要给已经运行的Apache增加mod_proxy模块,编译的时候应该这样:

apxs -c -i mod_proxy.c proxy_util.c

否则你可能会收到这样的错误信息

[root@server1 proxy]# /apache/httpd/bin/apachectl configtest
httpd: Syntax error on line 58 of /apache/httpd-2.2.3/conf/httpd.conf: Cannot load /apache/httpd-2.2.3/modules/mod_proxy.so into server: /apache/httpd-2.2.3/modules/mod_proxy.so: undefined symbol: proxy_lb_workers

加载后重新启动Apache
[root@server1 proxy]# /apache/httpd/bin/apachectl start

这样我可就可以重用重写和代理功能了。

apache安装命令行说明
http://httpd.apache.org/docs/2.2/programs/configure.html
您需要登录后才可以回帖 登录 | 立即注册 新浪微博账号登陆

本版积分规则

快速回复 返回顶部 返回列表