六狼论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

新浪微博账号登陆

只需一步,快速开始

搜索
查看: 202|回复: 0

配置Jboss Portal数据库为oracle

[复制链接]

升级  64%

8

主题

8

主题

8

主题

童生

Rank: 1

积分
32
 楼主| 发表于 2013-1-14 23:49:09 | 显示全部楼层 |阅读模式
Jboss Portal 支持oralce 9和oracle 10g数据库

配置步骤如下:
1.建立oracle用户名和表空间

在oracle中建立一个portal使用的用户名和表空间,用户名和表空间的名称无所谓,我起的是jportal。

2.更改jboss连接池配置

  A.将jboss-portal\setup\portal-oracle-ds.xml拷贝到jboss-portal\server\default\deploy下
  
  B.删除jboss-portal\server\default\deploy下原有的portal-hsqldb-ds.xml文件

  C.更改portal-oracle-ds.xml中的相关配置,有数据库连接URL,用户名和密码

3.拷贝oracle jdbc驱动程序

  注意:一定要拷最新的oracle jdbc驱动,负责后面的步骤会报错,我使用的是ojdbc14_g.jar,如果已安装的oracle 10g的客户端,则直接到jdbc目录下找。

  找到后将ojdbc14_g.jar拷到jboss-portal\server\default\lib下

4.启动jboss服务器

  启动后,等待一到两分钟,hibernate会将所有的数据表建立在oracle用户下。

启动完成后,输入http://localhost:8080/portal即可正常访问portal。
您需要登录后才可以回帖 登录 | 立即注册 新浪微博账号登陆

本版积分规则

快速回复 返回顶部 返回列表